FieldBuilder Class


Field Builder Class

This class is used to create Fields in the Extensible Storage framework.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.ExtensibleStorage FieldBuilder

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class FieldBuilder : IDisposable

The FieldBuilder type exposes the following members.

Constructors
Name Description
Public method FieldBuilder(FieldBuilder) Constructs a new copy of the input ESFieldBuilder object.
Public method FieldBuilder(Field, SchemaBuilder) Constructs a new FieldBuilder using the field and associated SchemaBuilder object.
Top
Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the FieldBuilder
Public method NeedsSubSchemaGUID Checks whether the SubSchema GUID needs to be explicitly specified for this field type.
Public method NeedsUnits Checks whether the field type requires explicit unit conversions.
Public method Ready Checks whether the builder may be used.
Public method SetDocumentation Sets the documentation string for the Field.
Public method SetSpec Sets the spec describing the field's values.
Public method SetSubSchemaGUID Sets the GUID of the Schema of the Entities that are intended to be stored in this field.
Top
See Also