Parameter Clear |
Clears the parameter to its initial value.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Return Value
BooleanThe ClearValue method will return True if the parameter was successfully cleared to its initial value, otherwise false.

Exception | Condition |
---|---|
InvalidOperationException | The parameter is read-only, or the parameter is not a shared parameter, or the shared parameter has HideWhenNoValue set to false. |

This method will only succeed for Shared parameters that have their HideWhenNoValue property set to true.