GetSectionData Method (SectionType)


Table Data Get Section Data(Section Type) Method

Returns the pointer to the section data array element at the specified section type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public TableSectionData GetSectionData(
	SectionType sectionType
)

Parameters

sectionType SectionType
The section type of section data array. If the integral value of the section type is out of the boundary of section data array, null is returned.

Return Value

TableSectionData
Exceptions
Exception Condition
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
See Also