ElectricalSystem Class


Electrical System Class

Provides access to the Electrical System in Autodesk Revit MEP.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB Element
Autodesk.Revit.DB MEPSystem
Autodesk.Revit.DB.Electrical ElectricalSystem

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class ElectricalSystem : MEPSystem

The ElectricalSystem type exposes the following members.

Properties
Name Description
Public property ApparentCurrent The ApparentCurrent value of the Electrical System.
Public property ApparentCurrentPhaseA The ApparentCurrentPhaseA value of the Electrical System.
Public property ApparentCurrentPhaseB The ApparentCurrentPhaseB value of the Electrical System.
Public property ApparentCurrentPhaseC The ApparentCurrentPhaseC value of the Electrical System.
Public property ApparentLoad The ApparentLoad value of the Electrical System.
Public property ApparentLoadPhaseA The ApparentLoadPhaseA value of the Electrical System.
Public property ApparentLoadPhaseB The ApparentLoadPhaseB value of the Electrical System.
Public property ApparentLoadPhaseC The ApparentLoadPhaseC value of the Electrical System.
Public property BalancedLoad Reports whether the BalancedLoad is on or off.
Public property CircuitConnectionType The circuit connection type of the electrical system.
Public property CircuitNamingIndex The Circuit Naming Index where the Electrical System is located in its panel. The Circuit Naming Index is used to retrieve the Circuit Naming Index of the Electrical System.
Public property CircuitNumber The CircuitNumber of the Electrical System.
Public property CircuitPathMode The circuit path mode of the electrical system.
Public property CircuitType The circuit type of the Electrical System.
Public property Frame The Frame value of the Electrical System.
Public property GroundConductorsNumber The GroundConductors Number of the Electrical System.
Public property HasCustomCircuitPath Checks whether the electrical system circuit path has been customized. If not, the property CircuitPathMode cannot be set as Custom explicitly.
Public property HasPathOffset Whether the circuit path has a valid offset.
Public property HotConductorsNumber The HotConductors Number of the Electrical System.
Public property IsBasePanelFeedThroughLugsOccupied Checks if the feed through lugs of the base panel is already occupied.
Public property Length The Length value of the Electrical System.
Public property LoadClassificationAbbreviations The LoadClassification Abbreviations used in the Electrical System.
Public property LoadClassifications The LoadClassifications used in the Electrical System.
Public property LoadName The LoadName of the Electrical System.
Public property NeutralConductorsNumber The NeutralConductors Number of the Electrical System.
Public property PanelName The Panel name of the Electrical System.
Public property PathOffset The offset of the horizontal segments of the circuit path.
Public property PhaseLabel The circuit phase label used in the Electrical System.
Public property PolesNumber The Poles Number of the Electrical System.
Public property PowerFactor The PowerFactor value of the Electrical System.
Public property PowerFactorState The PowerFactorState type of the Electrical System.
Public property Rating The Rating value of the Electrical System.
Public property RunsNumber The Runs Number of the Electrical System.
Public property SlotIndex The Slots where the Electrical System is located in its panel.
Public property StartSlot The Start Slot where the Electrical System is located in its panel.
Public property SystemType The Electrical System Type of the Electrical System.
Public property TrueCurrent The TrueCurrent value of the Electrical System.
Public property TrueCurrentPhaseA The TrueCurrentPhaseA value of the Electrical System.
Public property TrueCurrentPhaseB The TrueCurrentPhaseB value of the Electrical System.
Public property TrueCurrentPhaseC The TrueCurrentPhaseC value of the Electrical System.
Public property TrueLoad The TrueLoad value of the Electrical System.
Public property TrueLoadPhaseA The TrueLoadPhaseA value of the Electrical System.
Public property TrueLoadPhaseB The TrueLoadPhaseB value of the Electrical System.
Public property TrueLoadPhaseC The TrueLoadPhaseC value of the Electrical System.
Public property Voltage The Voltage value of the Electrical System.
Public property VoltageDrop The VoltageDrop value of the Electrical System.
Public property Ways The circuit ways used in the Electrical System.
Public property WireSizeString The WireSize as a String of the Electrical System
Public property WireType The wire type of the Electrical System.
Top
Methods
Name Description
Public method AddToCircuit Add a set of exist components to the Electrical System.
Public method Static member Create(Connector, ElectricalSystemType) Creates a new MEP Electrical System element from an unused Connector.
Public method Static member Create(Document, IList ElementId , ElectricalSystemType)
Public method DisconnectPanel Disconnect the panel for the Electrical System.
Public method GetCircuitPath Gets the list of the electrical system circuit path node position.
Public method IsCircuitPathValid
Public method NewWires Create a bunch of wires for the electrical system.
Public method RemoveFromCircuit remove a set of exist components from the Electrical System.
Public method SelectPanel Set the panel for the Electrical System.
Public method SetCircuitPath
Top
Remarks
The Electrical System object can only be queried in Autodesk Revit MEP.
See Also