ElectricalSystem Class


Electrical System Class

Provides access to the Electrical System in Autodesk Revit MEP.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB Element
Autodesk.Revit.DB MEPSystem
Autodesk.Revit.DB.Electrical ElectricalSystem

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class ElectricalSystem : MEPSystem

The ElectricalSystem type exposes the following members.

Properties
Name Description
Public property ApparentCurrent The ApparentCurrent value of the Electrical System.
Public property ApparentCurrentPhaseA The ApparentCurrentPhaseA value of the Electrical System.
Public property ApparentCurrentPhaseB The ApparentCurrentPhaseB value of the Electrical System.
Public property ApparentCurrentPhaseC The ApparentCurrentPhaseC value of the Electrical System.
Public property ApparentLoad The ApparentLoad value of the Electrical System.
Public property ApparentLoadPhaseA The ApparentLoadPhaseA value of the Electrical System.
Public property ApparentLoadPhaseB The ApparentLoadPhaseB value of the Electrical System.
Public property ApparentLoadPhaseC The ApparentLoadPhaseC value of the Electrical System.
Public property AssemblyInstanceId The id of the assembly instance to which the element belongs.
(Inherited from Element )
Public property BalancedLoad Reports whether the BalancedLoad is on or off.
Public property BaseEquipment The base panel or equipment of the system.
(Inherited from MEPSystem )
Public property BaseEquipmentConnector The connector within base equipment which is used to connect with system.
(Inherited from MEPSystem )
Public property BoundingBox Retrieves a box that circumscribes all geometry of the element.
(Inherited from Element )
Public property Category Retrieves a Category object that represents the category or sub category in which the element resides.
(Inherited from Element )
Public property CircuitConnectionType The circuit connection type of the electrical system.
Public property CircuitNamingIndex The Circuit Naming Index where the Electrical System is located in its panel. The Circuit Naming Index is used to retrieve the Circuit Naming Index of the Electrical System.
Public property CircuitNumber The CircuitNumber of the Electrical System.
Public property CircuitPathMode The circuit path mode of the electrical system.
Public property CircuitType The circuit type of the Electrical System.
Public property ConnectorManager Connector manager of the system.
(Inherited from MEPSystem )
Public property CreatedPhaseId Id of a Phase at which the Element was created.
(Inherited from Element )
Public property DemolishedPhaseId Id of a Phase at which the Element was demolished.
(Inherited from Element )
Public property DesignOption Returns the design option to which the element belongs.
(Inherited from Element )
Public property Document Returns the Document in which the Element resides.
(Inherited from Element )
Public property Elements Terminal elements in the system.
(Inherited from MEPSystem )
Public property Frame The Frame value of the Electrical System.
Public property Geometry Retrieves the geometric representation of the element.
(Inherited from Element )
Public property GroundConductorsNumber The GroundConductors Number of the Electrical System.
Public property GroupId The id of the group to which an element belongs.
(Inherited from Element )
Public property HasCustomCircuitPath Checks whether the electrical system circuit path has been customized. If not, the property CircuitPathMode cannot be set as Custom explicitly.
Public property HasDesignParts Indicates if the system has one or more design parts.
(Inherited from MEPSystem )
Public property HasFabricationParts Indicates if the system has one or more fabrication parts.
(Inherited from MEPSystem )
Public property HasPathOffset Whether the circuit path has a valid offset.
Public property HasPlaceholders Indicates if the system has one or more placeholders.
(Inherited from MEPSystem )
Public property HotConductorsNumber The HotConductors Number of the Electrical System.
Public property Id A unique identifier for an Element in an Autodesk Revit project.
(Inherited from Element )
Public property IsBasePanelFeedThroughLugsOccupied Checks if the feed through lugs of the base panel is already occupied.
Public property IsEmpty Indicates if the system is empty or not.
(Inherited from MEPSystem )
Public property IsModifiable Identifies if the element is modifiable.
(Inherited from Element )
Public property IsMultipleNetwork Indicates if the system is well connected or not. The flag will enable the "Divide System" button.
(Inherited from MEPSystem )
Public property IsTransient Indicates whether an element is transient or permanent.
(Inherited from Element )
Public property IsValid Indicates if the system is valid or not. atom AtomValidateSystem default false
(Inherited from MEPSystem )
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from Element )
Public property Length The Length value of the Electrical System.
Public property LevelId The id of the level associated with the element.
(Inherited from Element )
Public property LoadClassificationAbbreviations The LoadClassification Abbreviations used in the Electrical System.
Public property LoadClassifications The LoadClassifications used in the Electrical System.
Public property LoadName The LoadName of the Electrical System.
Public property Location This property is used to find the physical location of an element within a project.
(Inherited from Element )
Public property Name A human readable name for the Element.
(Inherited from Element )
Public property NeutralConductorsNumber The NeutralConductors Number of the Electrical System.
Public property OwnerViewId The id of the view that owns the element.
(Inherited from Element )
Public property PanelName The Panel name of the Electrical System.
Public property Parameter BuiltInParameter Retrieves a parameter from the element given a parameter id.
(Inherited from Element )
Public property Parameter Definition Retrieves a parameter from the element based on its definition.
(Inherited from Element )
Public property Parameter Guid Retrieves a parameter from the element given a GUID for a shared parameter.
(Inherited from Element )
Public property Parameters Retrieves a set containing all of the parameters that are contained within the element.
(Inherited from Element )
Public property ParametersMap Retrieves a map containing all of the parameters that are contained within the element.
(Inherited from Element )
Public property PathOffset The offset of the horizontal segments of the circuit path.
Public property PhaseLabel The circuit phase label used in the Electrical System.
Public property Pinned Identifies if the element has been pinned to prevent changes.
(Inherited from Element )
Public property PolesNumber The Poles Number of the Electrical System.
Public property PowerFactor The PowerFactor value of the Electrical System.
Public property PowerFactorState The PowerFactorState type of the Electrical System.
Public property PressureLossOfCriticalPath The total pressure loss of the sections in critical path.
(Inherited from MEPSystem )
Public property Rating The Rating value of the Electrical System.
Public property RunsNumber The Runs Number of the Electrical System.
Public property SectionsCount The number of sections.
(Inherited from MEPSystem )
Public property SlotIndex The Slots where the Electrical System is located in its panel.
Public property StartSlot The Start Slot where the Electrical System is located in its panel.
Public property SystemType The Electrical System Type of the Electrical System.
Public property TrueCurrent The TrueCurrent value of the Electrical System.
Public property TrueCurrentPhaseA The TrueCurrentPhaseA value of the Electrical System.
Public property TrueCurrentPhaseB The TrueCurrentPhaseB value of the Electrical System.
Public property TrueCurrentPhaseC The TrueCurrentPhaseC value of the Electrical System.
Public property TrueLoad The TrueLoad value of the Electrical System.
Public property TrueLoadPhaseA The TrueLoadPhaseA value of the Electrical System.
Public property TrueLoadPhaseB The TrueLoadPhaseB value of the Electrical System.
Public property TrueLoadPhaseC The TrueLoadPhaseC value of the Electrical System.
Public property UniqueId A stable unique identifier for an element within the document.
(Inherited from Element )
Public property VersionGuid Get the element version Guid.
(Inherited from Element )
Public property ViewSpecific Identifies if the element is owned by a view.
(Inherited from Element )
Public property Voltage The Voltage value of the Electrical System.
Public property VoltageDrop The VoltageDrop value of the Electrical System.
Public property Ways The circuit ways used in the Electrical System.
Public property WireSizeString The WireSize as a String of the Electrical System
Public property WireType The wire type of the Electrical System.
Public property WorksetId Get Id of the Workset which owns the element.
(Inherited from Element )
Top
Methods
Name Description
Public method Add Add elements into the system and connect them with the system using given connectors.
(Inherited from MEPSystem )
Public method AddToCircuit Add a set of exist components to the Electrical System.
Public method ArePhasesModifiable Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element.
(Inherited from Element )
Public method CanBeHidden Indicates if the element can be hidden in the view.
(Inherited from Element )
Public method CanBeLocked Identifies if the element can be locked.
(Inherited from Element )
Public method CanDeleteSubelement Checks if given subelement can be removed from the element.
(Inherited from Element )
Public method CanHaveTypeAssigned Identifies if the element can have a type assigned.
(Inherited from Element )
Public method ChangeTypeId(ElementId) Changes the type of the element.
(Inherited from Element )
Public method Static member Create(Connector, ElectricalSystemType) Creates a new MEP Electrical System element from an unused Connector.
Public method Static member Create(Document, IList ElementId , ElectricalSystemType)
Public method DeleteEntity Deletes the existing entity created by %schema% in the element
(Inherited from Element )
Public method DeleteSubelement Removes a subelement from the element.
(Inherited from Element )
Public method DeleteSubelements
(Inherited from Element )
Public method DisconnectPanel Disconnect the panel for the Electrical System.
Public method Dispose
(Inherited from Element )
Public method DivideSystem Divide the phyisical networks in the system and create a new system for each network.
(Inherited from MEPSystem )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method EvaluateAllParameterValues Evaluates all the parameters' values of the element.
(Inherited from Element )
Public method EvaluateParameterValues
(Inherited from Element )
Public method GetCircuitPath Gets the list of the electrical system circuit path node position.
Public method GetCriticalPathSectionNumbers Obtains a list of the critical path section numbers.
(Inherited from MEPSystem )
Public method GetDependentElements Get all elements that, from a logical point of view, are the children of this Element.
(Inherited from Element )
Public method GetEntity Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise.
(Inherited from Element )
Public method GetEntitySchemaGuids Returns the Schema guids of any Entities stored in this element.
(Inherited from Element )
Public method GetExternalFileReference Gets information pertaining to the external file referenced by the element.
(Inherited from Element )
Public method GetExternalResourceReference Gets the ExternalResourceReference associated with a specified external resource type.
(Inherited from Element )
Public method GetExternalResourceReferenceExpanded Gets the collection of ExternalResourceReference associated with a specified external resource type.
(Inherited from Element )
Public method GetExternalResourceReferences Gets the map of the external resource references referenced by the element.
(Inherited from Element )
Public method GetExternalResourceReferencesExpanded Gets the expanded map of the external resource references referenced by the element.
(Inherited from Element )
Public method GetGeneratingElementIds Returns the ids of the element(s) that generated the input geometry object.
(Inherited from Element )
Public method GetGeometryObjectFromReference Retrieve one geometric primitive contained in the element given a reference.
(Inherited from Element )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetMaterialArea Gets the area of the material with the given id.
(Inherited from Element )
Public method GetMaterialIds Gets the element ids of all materials present in the element.
(Inherited from Element )
Public method GetMaterialVolume Gets the volume of the material with the given id.
(Inherited from Element )
Public method GetMonitoredLinkElementIds Provides the link instance IDs when the element is monitoring.
(Inherited from Element )
Public method GetMonitoredLocalElementIds Provides the local element IDs when the element is monitoring.
(Inherited from Element )
Public method GetOrderedParameters Gets the parameters associated to the element in order.
(Inherited from Element )
Public method GetParameter Retrieves a parameter from the element given identifier.
(Inherited from Element )
Public method GetParameterFormatOptions Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists.
(Inherited from Element )
Public method GetParameters Retrieves the parameters from the element via the given name.
(Inherited from Element )
Public method GetPhaseStatus Gets the status of a given element in the input phase
(Inherited from Element )
Public method GetPhysicalNetworksNumber Get the physical networks number in the system.
(Inherited from MEPSystem )
Public method GetSectionByIndex Get the section from the index.
(Inherited from MEPSystem )
Public method GetSectionByNumber Get the Section from section number
(Inherited from MEPSystem )
Public method GetSubelements Returns the collection of element subelements.
(Inherited from Element )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method GetTypeId Returns the identifier of this element's type.
(Inherited from Element )
Public method GetValidTypes Obtains a set of types that are valid for this element.
(Inherited from Element )
Public method HasPhases Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId.
(Inherited from Element )
Public method IsCircuitPathValid
Public method IsCreatedPhaseOrderValid Returns true if createdPhaseId and demolishedPhaseId are in order.
(Inherited from Element )
Public method IsDemolishedPhaseOrderValid Returns true if createdPhaseId and demolishedPhaseId are in order.
(Inherited from Element )
Public method IsExternalFileReference Determines whether this Element represents an external file.
(Inherited from Element )
Public method IsHidden Identifies if the element has been permanently hidden in the view.
(Inherited from Element )
Public method IsMonitoringLinkElement Indicate whether an element is monitoring any elements in any linked models.
(Inherited from Element )
Public method IsMonitoringLocalElement Indicate whether an element is monitoring other local elements.
(Inherited from Element )
Public method IsPhaseCreatedValid Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element.
(Inherited from Element )
Public method IsPhaseDemolishedValid Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element.
(Inherited from Element )
Public method IsSystemDividable Checks if the system is dividable. The system is dividable if there is more than one physical network in the system. Currently, only HVAC and piping systems support dividing.
(Inherited from MEPSystem )
Public method IsValidType(ElementId) Checks if given type is valid for this element.
(Inherited from Element )
Public method LookupParameter Attempts to find a parameter on the element which has the given name.
(Inherited from Element )
Public method NewWires Create a bunch of wires for the electrical system.
Public method RefersToExternalResourceReference Determines whether this Element uses external resources associated with a specified external resource type.
(Inherited from Element )
Public method RefersToExternalResourceReferences Determines whether this Element uses external resources.
(Inherited from Element )
Public method Remove(ConnectorSet) Removes connectors from system.
(Inherited from MEPSystem )
Public method Remove(ICollection ElementId )
(Inherited from MEPSystem )
Public method RemoveFromCircuit remove a set of exist components from the Electrical System.
Public method SelectPanel Set the panel for the Electrical System.
Public method SetCircuitPath
Public method SetEntity Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten.
(Inherited from Element )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks
The Electrical System object can only be queried in Autodesk Revit MEP.
See Also