ResetMovedBarTransform Method


Rebar In System Reset Moved Bar Transform Method

Reset the transformation representing the movement of the bar relative to its default position along the distribution path. The moved bar transform will be set to Identity.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void ResetMovedBarTransform(
	int barPositionIndex
)

Parameters

barPositionIndex Int32
The bar index.
Exceptions
Exception Condition
ArgumentOutOfRangeException barPositionIndex is not in the range [ 0, NumberOfBarPositions-1 ].
InapplicableDataException For this RebarInSystem element individual bars can't be moved, excluded or included.
See Also