Multi |
If the DimensionStyleType is LinearFixed, this function verifies that the dimension line direction matches either the view's vertical or horizontal direction.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static bool IsLinearFixedDimensionDirectionValid(
Document document,
ElementId viewId,
MultiReferenceAnnotationOptions options
)
Parameters
- document Document
- The document for the view.
- viewId ElementId
- The view in which the dimension line direction will be tested.
- options MultiReferenceAnnotationOptions
- Options containing the DimensionStyleType and dimension line direction to test.
Return Value
BooleanTrue if the DimensionStyleType is LinearFixed and the dimension line direction can be used in the view. True if the DimensionStyleType is not LinearFixed.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |