AlignmentStationLabelSetOptions Class


Alignment Station Label Set Options Class

Represents an object containing options for creating a set of AlignmentStationLabel .
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Infrastructure AlignmentStationLabelSetOptions

Namespace: Autodesk.Revit.DB.Infrastructure
Assembly: Autodesk.CivilAlignments.DBApplication (in Autodesk.CivilAlignments.DBApplication.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class AlignmentStationLabelSetOptions

The AlignmentStationLabelSetOptions type exposes the following members.

Constructors
Name Description
Public method AlignmentStationLabelSetOptions Create an object with default values.
Top
Properties
Name Description
Public property EndStation The ending station for creating labels in the set, in Revit internal model units (standard Imperial feet). The default value is null. When null, the station value corresponding to the alignment's DisplayedEndStation is used.
Public property HasLeader Specifies if the label will have a leader. The default value is true.
Public property Interval The interval between labels to be created in the set, in Revit internal model units (standard Imperial feet). The default value is null. When null, a predefined interval value will be used, depending on the unit setting for stationing units in the document. For standard imperial, the default is 100 ft. For survey imperial, the default is 100 USft (US survey). For metric, the default is 1000 m.
Public property Offset The offset of the labels from the alignment, in Revit internal paper space units (standard Imperial feet). A positive offset creates labels to the right of the alignment, a negative - to the left. The default value is null. If null, a predefined offset value will be used, depending on the unit setting for stationing units in the document. For standard imperial, the default is 1/8". For survey imperial, the default is 1/8" (US survey). For metric, the default is 5 mm.
Public property StartStation The starting station for creating labels in the set, in Revit internal model units (standard Imperial feet). The default value is null. When null, the station value corresponding to the alignment's DisplayedStartStation is used.
Public property TypeId Specifies the ElementId of the labels' type. The default value is InvalidElementId. in this case, CreateSet(Alignment, View, AlignmentStationLabelSetOptions) will throw an exception.
Top
Methods
Name Description
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also