Routing |
RoutingConditions contain routing information that is used as input when determining if a routing criterion, such as minimum or maximum diameter, is met.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The RoutingConditions type exposes the following members.

Name | Description | |
---|---|---|
![]() | RoutingConditions | Constructs a new instance of a RoutingConditions object with an indicated error level for conditions that do not meet any routing preference rule. |

Name | Description | |
---|---|---|
![]() | ErrorLevel | The error level that the routing preference manager should post errors if the routing conditions do not meet any routing preference rule, could be None, Warning, or Error |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |
![]() | PreferredJunctionType | The junction type (Tee or Tap) to select if defined fittings of both junction types meet all routing conditions. |

Name | Description | |
---|---|---|
![]() | AppendCondition | Appends a routing condition to the end of existing routing conditions. Note that the first item (indexed at 0) is the condition for the primary connector. |
![]() | Clear | Clear all existing conditions |
![]() | Dispose | Releases all resources used by the RoutingConditions |
![]() | GetConditionAt | Gets the routing condition at the specified index position. |
![]() | GetNumberOfConditions | Gets the number of included routing conditions. |