RebarShapeMatchesCurvesAndHooks Method


Rebar Rebar Shape Matches Curves And Hooks Method


Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static bool RebarShapeMatchesCurvesAndHooks(
	RebarShape rebarShape,
	RebarBarType barType,
	XYZ norm,
	IList<Curve> curves,
	RebarHookType startHook,
	RebarHookType endHook,
	RebarHookOrientation startHookOrient,
	RebarHookOrientation endHookOrient
)

Parameters

rebarShape RebarShape
barType RebarBarType
norm XYZ
curves IList Curve
startHook RebarHookType
endHook RebarHookType
startHookOrient RebarHookOrientation
endHookOrient RebarHookOrientation

Return Value

Boolean
See Also