ExportIFCCategoryKey(String, String, CustomSubCategoryId) Constructor


Export IFCCategory Key(String, String, Custom Sub Category Id) Constructor

Constructs a new ExportIFCCategoryKey with category, subcategory names and special id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ExportIFCCategoryKey(
	string categoryName,
	string subCategoryName,
	CustomSubCategoryId customSubCategoryId
)

Parameters

categoryName String
The Revit category name.
subCategoryName String
The Revit subcategory name.
customSubCategoryId CustomSubCategoryId
The Revit custom subcategory id.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
See Also