ExportPatternInfo Class


Export Pattern Info Class

A value used to represent the info stored in the ExportPatternTable .
Inheritance Hierarchy
System Object
Autodesk.Revit.DB ExportPatternInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ExportPatternInfo : IDisposable

The ExportPatternInfo type exposes the following members.

Constructors
Name Description
Public method ExportPatternInfo Constructs a new default ExportPatternInfo.
Public method ExportPatternInfo(ExportPatternInfo) Constructs a new copy of the input ExportPatternInfo object.
Public method ExportPatternInfo(String) Constructs a new ExportPatternInfo using the destination pattern name as input.
Top
Properties
Name Description
Public property DestinationPatternName The destination pattern name (the name of the pattern in the exported format).
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the ExportPatternInfo
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also