Element |
A filter to find elements that intersect the given solid geometry.

System Object
Autodesk.Revit.DB ElementFilter
Autodesk.Revit.DB ElementSlowFilter
Autodesk.Revit.DB ElementIntersectsFilter
Autodesk.Revit.DB ElementIntersectsSolidFilter
Autodesk.Revit.DB ElementFilter
Autodesk.Revit.DB ElementSlowFilter
Autodesk.Revit.DB ElementIntersectsFilter
Autodesk.Revit.DB ElementIntersectsSolidFilter
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)

The ElementIntersectsSolidFilter type exposes the following members.

Name | Description | |
---|---|---|
![]() | ElementIntersectsSolidFilter(Solid) | Constructs a filter to match elements which intersect the given element. |
![]() | ElementIntersectsSolidFilter(Solid, Boolean) | Constructs a filter to match elements which intersect the given element, with the option to match all elements not intersecting the given element. |

Name | Description | |
---|---|---|
![]() | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter ) |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter ) |

Name | Description | |
---|---|---|
![]() | Dispose | (Inherited from ElementFilter ) |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetSolid | Gets the target solid geometry. |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter ) |
![]() | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |

The input solid used for this filter can be obtained from an existing element, created from scratch using the routines in GeometryCreationUtilities or builder classes, or the generated from the result of a secondary operation such as a Boolean operation. Similar to the ElementIntersectsElementFilter , this filter will not detect as intersecting elements which lack solid geometry, such as Rebar.
This filter is a slow filter. Slow filters require that the Element be obtained and expanded in memory first. Thus it is preferable to couple this filter with at least one ElementQuickFilter, which should minimize the number of Elements that are expanded.