ConnectionInputPointInfo Class


Connection Input Point Info Class

An object that holds description information about a connection input point
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Structure ConnectionInputPointInfo

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ConnectionInputPointInfo : IDisposable

The ConnectionInputPointInfo type exposes the following members.

Constructors
Name Description
Public method ConnectionInputPointInfo Construct a default input point.
Public method ConnectionInputPointInfo(String, Int32, String) Construct an input point info.
Top
Properties
Name Description
Public property InputMemberIndex A index of the input member to which the restriction applies.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property PointSelectionText A string used to select input point by some connections.
Public property RestrictionType A type of input point restriction.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the ConnectionInputPointInfo
Top
See Also