Schedule |
Adds a new filter at the end of the list.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)

Parameters
- filter ScheduleFilter
- The filter to add.

Exception | Condition |
---|---|
ArgumentException | The field ID is not the ID of a field in this ScheduleDefinition. -or- The field and filter type cannot be used to filter this ScheduleDefinition. -or- The filter value is not valid for the field and filter type. |
ArgumentNullException | A non-optional argument was null |
InvalidOperationException | This ScheduleDefinition does not support filters. -or- The resulting filter count would be greater than 8. |