IsTypeNameValidForCustomConnection Method


Structural Connection Handler Type Is Type Name Valid For Custom Connection Method

Validates if the input name matches the criteria of StructuralConnectionHandlerType name. Name must be unique among other existing StructuralConnectionHandlerTypes and cannot contain any of the following characters: new line, {}[];`~\\/:*?";<>| or any of the non-printable characters.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static bool IsTypeNameValidForCustomConnection(
	Document document,
	string typeName
)

Parameters

document Document
The Document.
typeName String
The StructuralConnectionHandlerType name to validate.

Return Value

Boolean
True if the input name matches the criteria of StructuralConnectionHandlerType name.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also