PreviewControl Constructor


Preview Control Constructor

Constructs a preview control.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public PreviewControl(
	Document document,
	ElementId viewId
)

Parameters

document Document
The document.
viewId ElementId
The view id want to browse in this control.
Exceptions
Exception Condition
ArgumentNullException Thrown when dbDocument or viewId is .
ArgumentException Thrown when the given document is a linked document or the given viewId is invalid or the view is a schedule or other non-graphical view such as schedule views or the project browser view.
InvalidOperationException Thrown when there is an active preview control already.
See Also