MEPSystem Divide |
Divide the phyisical networks in the system and create a new system for each network.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- ADoc Document
- The document.
Return Value
ICollection ElementIdThe id of new created systems.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |
InvalidOperationException | The system is not dividable. |

This function only works for Hvac and Piping system.