Document |
The event arguments used by the DocumentSavingAs event.

System Object
System EventArgs
Autodesk.Revit.DB.Events RevitAPIEventArgs
Autodesk.Revit.DB.Events RevitAPIPreEventArgs
Autodesk.Revit.DB.Events RevitAPIPreDocEventArgs
Autodesk.Revit.DB.Events DocumentSavingAsEventArgs
System EventArgs
Autodesk.Revit.DB.Events RevitAPIEventArgs
Autodesk.Revit.DB.Events RevitAPIPreEventArgs
Autodesk.Revit.DB.Events RevitAPIPreDocEventArgs
Autodesk.Revit.DB.Events DocumentSavingAsEventArgs
Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The DocumentSavingAsEventArgs type exposes the following members.

Name | Description | |
---|---|---|
![]() | IsSavingAsCentralFile | Indicates whether the document is to be saved as central file. |
![]() | PathName | Target path to which the document is to be saved. |

Name | Description | |
---|---|---|