Document |
The event arguments used by the DocumentSavingAs event.

System Object
System EventArgs
Autodesk.Revit.DB.Events RevitAPIEventArgs
Autodesk.Revit.DB.Events RevitAPIPreEventArgs
Autodesk.Revit.DB.Events RevitAPIPreDocEventArgs
Autodesk.Revit.DB.Events DocumentSavingAsEventArgs
System EventArgs
Autodesk.Revit.DB.Events RevitAPIEventArgs
Autodesk.Revit.DB.Events RevitAPIPreEventArgs
Autodesk.Revit.DB.Events RevitAPIPreDocEventArgs
Autodesk.Revit.DB.Events DocumentSavingAsEventArgs
Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The DocumentSavingAsEventArgs type exposes the following members.

Name | Description | |
---|---|---|
![]() | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitAPIEventArgs ) |
![]() | Document | The document associated with the event. (Inherited from RevitAPIPreDocEventArgs ) |
![]() | IsSavingAsCentralFile | Indicates whether the document is to be saved as central file. |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from RevitAPIEventArgs ) |
![]() | PathName | Target path to which the document is to be saved. |

Name | Description | |
---|---|---|
![]() | Cancel | When the event is cancellable, may call the Cancel() method to cancel it. (Inherited from RevitAPIPreEventArgs ) |
![]() | Dispose | (Inherited from RevitAPIEventArgs ) |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | IsCancelled | Indicates whether the event is being cancelled. (Inherited from RevitAPIEventArgs ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |