NewReferencePlane Method


Item Factory Base New Reference Plane Method

Creates a new instance of ReferencePlane.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public ReferencePlane NewReferencePlane(
	XYZ bubbleEnd,
	XYZ freeEnd,
	XYZ cutVec,
	View pView
)

Parameters

bubbleEnd XYZ
The bubble end applied to reference plane.
freeEnd XYZ
The free end applied to reference plane.
cutVec XYZ
The cut vector apply to reference plane, should perpendicular to the vector (bubbleEnd-freeEnd).
pView View
The specific view apply to the Reference plane.

Return Value

ReferencePlane
The newly created reference plane.
Remarks
The specific view is applied to the Reference plane only for certain view types: Legend DraftingView DrawingSheet
See Also