Create Method


Railing Create(Document, Element Id, Element Id, Railing Placement Position) Method

Automatically creates new railings with the specified railing type on all sides of a stairs or ramp element.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static ICollection<ElementId> Create(
	Document document,
	ElementId stairsOrRampId,
	ElementId railingTypeId,
	RailingPlacementPosition placePosition
)

Parameters

document Document
The document.
stairsOrRampId ElementId
The stairs or ramp to which the new railing will host. The stairs or ramp should have no associated railings yet. If the stairs are a part of MultistoryStairs element railings will be populated on all levels.
railingTypeId ElementId
The railing type of the new railing to be created.
placePosition RailingPlacementPosition
The placement position of the new railing.

Return Value

ICollection ElementId
The new railing instances successfully created on the stairs.
Exceptions
Exception Condition
ArgumentException The stairsOrRampId is not a stairs or ramp element. -or- The railingTypeId is not a railing type.
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException The stairsOrRampId already has associated railings or is in editing mode so association of railings is not permitted.
ModificationForbiddenException The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException The document has no open transaction.
See Also