Create Method


MEPAnalytical System Create Method

Creates a new analytical system

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static MEPAnalyticalSystem Create(
	Document document,
	AnalyticalSystemDomain domain,
	string name
)

Parameters

document Document
The document where the new element will be created.
domain AnalyticalSystemDomain
The domain of analytical system to be created.
name String
The name of new analytical system. The actual name may be post-fixed if already exists.

Return Value

MEPAnalyticalSystem
The newly created analytical system.
Exceptions
Exception Condition
ArgumentException name cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~". -or- name is an empty string.
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements).
ModificationForbiddenException The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException The document has no open transaction.
See Also