TemporaryGraphicsManager Class


Temporary Graphics Manager Class

A class that provides functionality to create temporary graphics in a Revit model.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB TemporaryGraphicsManager

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class TemporaryGraphicsManager : IDisposable

The TemporaryGraphicsManager type exposes the following members.

Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method AddControl Creates an in-canvas control.
Public method Clear Clear all temporary graphics objects managed by this manager.
Public method Dispose Releases all resources used by the TemporaryGraphicsManager
Public method GetAll Returns all temporary graphics object indexes managed by this manager.
Public method Static member GetTemporaryGraphicsManager Gets a TemporaryGraphicsManager reference of the document.
Public method RemoveControl Deletes the existing control identified by the unique index.
Public method SetVisibility Changes the visibility of temporary graphics object.
Public method UpdateControl Updates the in-canvas control identified by the unique index.
Top
Remarks

The graphics created by this class are temporary or transient. They are not subject to undo and are not saved. It's caller's responsiblity to manage their lifetime, creation and destruction, though Revit will destroy all of them when closing the model.

See Also