AdvancedWood Class


Advanced Wood Class

A static class that provides access to the property names that appear in the AdvancedWood visual asset schema.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Visual AdvancedWood

Namespace: Autodesk.Revit.DB.Visual
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class AdvancedWood

The AdvancedWood type exposes the following members.

Properties
Name Description
Public property Static member WoodCurlyDistortionEnable The property labeled "Enable distortion for wood secondary curly highlight" from the "AdvancedWood" schema.
Public property Static member WoodCurlyDistortionMap The property labeled "The 2D fiber distortion map (NO degamma op)" from the "AdvancedWood" schema.
Public property Static member WoodCurlyDistortionScale The property labeled "The scale of distortion for secondary curly highlight" from the "AdvancedWood" schema.
Public property Static member WoodDiffuseLobeWeight The property labeled "Weight of diffuse lobe" from the "AdvancedWood" schema.
Public property Static member WoodDiffusePerlinEnable The property labeled "Use perlin function for diffuse albedo" from the "AdvancedWood" schema.
Public property Static member WoodDiffusePerlinProf The property labeled "Profile for diffuse albedo perlin noise" from the "AdvancedWood" schema.
Public property Static member WoodDiffusePerlinScaleZ The property labeled "Anisotropic pos-z scale for diffuse albedo perlin" from the "AdvancedWood" schema.
Public property Static member WoodEarlyColor The property labeled "Earlywood color" from the "AdvancedWood" schema.
Public property Static member WoodEarlycolorPerlinEnable The property labeled "Use perlin noise for earlywood color" from the "AdvancedWood" schema.
Public property Static member WoodEarlycolorPerlinProf The property labeled "Profile for earlywood color perlin noise" from the "AdvancedWood" schema.
Public property Static member WoodEarlywoodSharpness The property labeled "Percentage of pure earlywood" from the "AdvancedWood" schema.
Public property Static member WoodFiberCosineEnable The property labeled "Use cosine function for wood fiber" from the "AdvancedWood" schema.
Public property Static member WoodFiberCosineProf The property labeled "Profile for fiber cosine function" from the "AdvancedWood" schema.
Public property Static member WoodFiberPerlinEnable The property labeled "Use perlin noise for wood fiber" from the "AdvancedWood" schema.
Public property Static member WoodFiberPerlinProf The property labeled "Profile for fiber perlin noise" from the "AdvancedWood" schema.
Public property Static member WoodFiberPerlinScaleZ The property labeled "Anisotropic pos-z scale for fiber perlin" from the "AdvancedWood" schema.
Public property Static member WoodFiberRoughness The property labeled "Roughness for secondary highlight" from the "AdvancedWood" schema.
Public property Static member WoodGrooveRoughness The property labeled "Roughness for surface groove area" from the "AdvancedWood" schema.
Public property Static member WoodGrowthPerlinEnable The property labeled "Use perlin noise for ring growth" from the "AdvancedWood" schema.
Public property Static member WoodGrowthPerlinProf The property labeled "Profile for growth perlin noise" from the "AdvancedWood" schema.
Public property Static member WoodLatecolorPerlinEnable The property labeled "Use perlin noise for latewood color" from the "AdvancedWood" schema.
Public property Static member WoodLatecolorPerlinProf The property labeled "Profile for latewood color perlin noise" from the "AdvancedWood" schema.
Public property Static member WoodLateColorPower The property labeled "Power to compute latewood color" from the "AdvancedWood" schema.
Public property Static member WoodLatewoodBumpDepth The property labeled "Depth (cm) of the latewood bump" from the "AdvancedWood" schema.
Public property Static member WoodLatewoodRatio The property labeled "Percentage of latewood in each ring" from the "AdvancedWood" schema.
Public property Static member WoodLatewoodSharpness The property labeled "Percentage of pure latewood" from the "AdvancedWood" schema.
Public property Static member WoodManualLateColor The property labeled "Manual latewood color" from the "AdvancedWood" schema.
Public property Static member WoodPoreCellDim The property labeled "Dim (cm) of cell containing one pore" from the "AdvancedWood" schema.
Public property Static member WoodPoreColorPower The property labeled "Power to compute pore color" from the "AdvancedWood" schema.
Public property Static member WoodPoreDepth The property labeled "Bump depth variation (cm) for pores" from the "AdvancedWood" schema.
Public property Static member WoodPoreRadius The property labeled "Radius (cm) of the impact circle of each pore" from the "AdvancedWood" schema.
Public property Static member WoodPoreType The property labeled "Pore type" from the "AdvancedWood" schema.
Public property Static member WoodRayColorPower The property labeled "Power to compute ray color" from the "AdvancedWood" schema.
Public property Static member WoodRayEllipseRadiusX The property labeled "Radius (cm) along the longer axis of ray ellipse" from the "AdvancedWood" schema.
Public property Static member WoodRayEllipseZ2x The property labeled "Ratio between two radii of ray ellipse" from the "AdvancedWood" schema.
Public property Static member WoodRayNumSlices The property labeled "Number of slices in xy plane" from the "AdvancedWood" schema.
Public property Static member WoodRaySegLengthZ The property labeled "Length (cm) of z segment containing one ray" from the "AdvancedWood" schema.
Public property Static member WoodRingThickness The property labeled "Thickness (cm) of yearly growth ring" from the "AdvancedWood" schema.
Public property Static member WoodSecondaryColorPower The property labeled "Power to compute secondary highlight color" from the "AdvancedWood" schema.
Public property Static member WoodSecondaryPerlinEnable The property labeled "Use perlin noise for secondary highlight" from the "AdvancedWood" schema.
Public property Static member WoodSecondaryPerlinProf The property labeled "Profile for secondary highlight perlin noise" from the "AdvancedWood" schema.
Public property Static member WoodSecondaryPerlinScaleZ The property labeled "Anisotropic pos-z scale for secondary highlight perlin" from the "AdvancedWood" schema.
Public property Static member WoodUseGrooveRoughness The property labeled "Use additional groove roughness" from the "AdvancedWood" schema.
Public property Static member WoodUseLatewoodBump The property labeled "Use latewood bump" from the "AdvancedWood" schema.
Public property Static member WoodUseManualLateColor The property labeled "Use manual latewood color" from the "AdvancedWood" schema.
Public property Static member WoodUsePores The property labeled "Use pores feature" from the "AdvancedWood" schema.
Public property Static member WoodUseRays The property labeled "Use rays feature" from the "AdvancedWood" schema.
Top
See Also