Outline Class


Outline Class

Outline is a generic object that provides a bounding box/bounding outline. It supports operations to scale and transform. It also supports intersections and contains operations.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB Outline

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class Outline : IDisposable

The Outline type exposes the following members.

Constructors
Name Description
Public method Outline(Outline) Constructs a new copy of the input Outline object.
Public method Outline(XYZ, XYZ) Constructor that uses a minimum and maximum XYZ point to initialize the outline.
Top
Properties
Name Description
Public property IsEmpty Identifies if the outline represents an empty outline.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property MaximumPoint The maximum point of the bounding box.
Public property MinimumPoint The minimum point of the bounding box.
Top
Methods
Name Description
Public method AddPoint Adds a point to the bounding box, expanding it if the point is outside the existing boundary.
Public method Contains Determine if this Outline contains the specified point to within a tolerance.
Public method ContainsOtherOutline Determine if this Outline contains another Outline to within tolerance.
Public method Dispose Releases all resources used by the Outline
Public method GetDiagonalLength Get the length of outline's diagonal. If called on empty outline, 0. is returned
Public method Intersects Determine if this Outline intersects the input Outline to within a specified tolerance.
Public method IsScaleValid Checks if given scale is valid. Should be greater than zero.
Public method Scale Scales the bounding box by given scale.
Top
See Also