Export Method (String, String, OBJExportOptions)


Document Export(String, String, OBJExport Options) Method

Exports a view specified in the export options to the OBJ format.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool Export(
	string folder,
	string name,
	OBJExportOptions options
)

Parameters

folder String
Output folder into which the file will be exported. The folder must exist.
name String
Indicates the name of the OBJ file to export. If it doesn't end with ".obj", this extension will be added automatically. The name cannot contain any of the following characters: \/:*?"<>|. Empty name is not acceptable.
options OBJExportOptions
Various options applicable to the OBJ format.

Return Value

Boolean
True if successful, otherwise False.
Exceptions
Exception Condition
ArgumentException NullOrEmpty -or- Contains invalid characters. -or- The provided options do not specify a printable 3D view.
ArgumentNullException A non-optional argument was null
ForbiddenForDynamicUpdateException This method may not be called during dynamic update.
InvalidOperationException Export is temporarily disabled. -or- Exporting is not allowed in the current application mode.
InvalidPathArgumentException The folder does not exist.
OptionalFunctionalityNotAvailableException The ShapeExporter functionality is not available in the installed Revit, or the Material Library is missing.
See Also