Recenter Method


Spatial Element Recenter Method

Moves the spatial element to its default location.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public void Recenter()
Exceptions
Exception Condition
InvalidOperationException The spatial element does not have a valid default location.
Remarks
The default location is a point where a spatial element is placed when it is created automatically without specifying a point. The default location of a spatial element is identical to the center of the bounding box if it is located inside the boundary, otherwise Revit will try to find a point that is guaranteed to be inside the boundary using an internal algorithm.
See Also