Rebar |
A dimension or other constraint that takes part in a RebarShapeDefinition.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The RebarShapeConstraint type exposes the following members.

Name | Description | |
---|---|---|
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the RebarShapeConstraint |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetParamId | Return the Id of the parameter associated with this constraint. |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |

Reference

System Object
Autodesk.Revit.DB.Structure RebarShapeConstraint
Autodesk.Revit.DB.Structure RebarShapeConstraint180DegreeBendArcLength
Autodesk.Revit.DB.Structure RebarShapeConstraint180DegreeBendRadius
Autodesk.Revit.DB.Structure RebarShapeConstraint180DegreeDefaultBend
Autodesk.Revit.DB.Structure RebarShapeConstraintAngleFromFixedDir
Autodesk.Revit.DB.Structure RebarShapeConstraintArcLength
Autodesk.Revit.DB.Structure RebarShapeConstraintChordLength
Autodesk.Revit.DB.Structure RebarShapeConstraintCircumference
Autodesk.Revit.DB.Structure RebarShapeConstraintDiameter
Autodesk.Revit.DB.Structure RebarShapeConstraintFixedSegmentDir
Autodesk.Revit.DB.Structure RebarShapeConstraintProjectedSegmentLength
Autodesk.Revit.DB.Structure RebarShapeConstraintRadius
Autodesk.Revit.DB.Structure RebarShapeConstraintSagittaLength
Autodesk.Revit.DB.Structure RebarShapeConstraintSegmentLength
Autodesk.Revit.DB.Structure RebarShapeConstraint
Autodesk.Revit.DB.Structure RebarShapeConstraint180DegreeBendArcLength
Autodesk.Revit.DB.Structure RebarShapeConstraint180DegreeBendRadius
Autodesk.Revit.DB.Structure RebarShapeConstraint180DegreeDefaultBend
Autodesk.Revit.DB.Structure RebarShapeConstraintAngleFromFixedDir
Autodesk.Revit.DB.Structure RebarShapeConstraintArcLength
Autodesk.Revit.DB.Structure RebarShapeConstraintChordLength
Autodesk.Revit.DB.Structure RebarShapeConstraintCircumference
Autodesk.Revit.DB.Structure RebarShapeConstraintDiameter
Autodesk.Revit.DB.Structure RebarShapeConstraintFixedSegmentDir
Autodesk.Revit.DB.Structure RebarShapeConstraintProjectedSegmentLength
Autodesk.Revit.DB.Structure RebarShapeConstraintRadius
Autodesk.Revit.DB.Structure RebarShapeConstraintSagittaLength
Autodesk.Revit.DB.Structure RebarShapeConstraintSegmentLength