Solid |
Creates a new Solid which is the transformation of the input Solid.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- solid Solid
- The input solid to be transformed.
- transform Transform
- The transform (which must be conformal).
Return Value
SolidThe newly created Solid.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |
ArgumentOutOfRangeException | transform is not conformal. -or- transform has a scale that is negative or zero. |