GetMinimumAllowedWidth Method (Document, ElementId)


Text Element Get Minimum Allowed Width(Document, Element Id) Method

Returns the minimum width a text element can be created with.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static double GetMinimumAllowedWidth(
	Document cdda,
	ElementId typeId
)

Parameters

cdda Document
A document containing the new text element's type
typeId ElementId
Id of the text type

Return Value

Double
The minimum allowed width in paper space [ft].
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
Remarks
Note that it is not necessarily a constant; it can be affected by properties of the text type, such as the width factor.
See Also