TransformAndScalePoint Method


Exporter IFCUtils Transform And Scale Point Method

Converts a point from global Revit coordinates to current IFC coordinates, including scale.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static XYZ TransformAndScalePoint(
	ExporterIFC exporterIFC,
	XYZ origPt
)

Parameters

exporterIFC ExporterIFC
The exporter.
origPt XYZ
The original point.

Return Value

XYZ
The transformed and scaled point.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also