RevitLinkGraphicsSettings Class


Revit Link Graphics Settings Class

Settings to override display of Revit link in a view.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB RevitLinkGraphicsSettings

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class RevitLinkGraphicsSettings : IDisposable

The RevitLinkGraphicsSettings type exposes the following members.

Constructors
Name Description
Public method RevitLinkGraphicsSettings Creates a new RevitLinkGraphicsSettings instance.
Top
Properties
Name Description
Public property ColorFill The color fill of RevitLinkGraphicsSettings. The color fill can be set to ByHostView or ByLinkView . Only a view that supports color fill can have this property set to ByLinkView . To check if the view supports the color fill use SupportedColorFillCategoryIds to see if there is any supported color fill category for the view. The LinkedViewId parameter must have a value assigned if this property is set to ByLinkView .
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property LinkedViewId The id of the linked view associated with this RevitLinkGraphicsSettings, or InvalidElementId if no view is selected. If the LinkVisibilityType is set to ByLinkView , then there must be a valid LinkedViewId.
Public property LinkVisibilityType The visibility type of RevitLinkGraphicsSettings. If the type is set to ByHostView or ByLinkView , then the dependent properties of RevitLinkGraphicsSettings will be reset to their default state. The state of dependent properties can be changed later.
Public property NestedLinks The nested links of RevitLinkGraphicsSettings. The nested links can be set to ByHostView or ByLinkView .
Public property ObjectStyles The object styles of RevitLinkGraphicsSettings. The object styles can be set to ByHostView or ByLinkView .
Public property ViewFilterType The view filter type of RevitLinkGraphicsSettings. If the LinkVisibilityType is set to ByHostView , then the view filter type should be set to ByHostView . If the LinkVisibilityType is set to ByLinkView , then the view filter type should be set to ByLinkView . If the LinkVisibilityType is set to Custom , then the view filter type can be set to any value from LinkVisibility enum. The LinkedViewId parameter must have a value assigned if this property is set to ByLinkView . The Custom value corresponds to None option in the UI.
Public property ViewRange The view range of RevitLinkGraphicsSettings. The view range can be set to ByHostView or ByLinkView . Only a view that supports view range can have this property set to ByLinkView . To check if the view supports the view range use [!:Autodesk::Revit::DB::LinkVisibility::IsViewRangeSupported(Autodesk::Revit::DB::LinkVisibility)] . The LinkedViewId parameter must have a value assigned if this property is set to ByLinkView .
Top
Methods
Name Description
Public method Dispose Releases all resources used by the RevitLinkGraphicsSettings
Public method GetDiscipline The linked document discipline of RevitLinkGraphicsSettings.
Public method GetDisciplineType The discipline type of RevitLinkGraphicsSettings.
Public method GetPhaseFilterId The linked document phase filter id of RevitLinkGraphicsSettings, or InvalidElementId if there is no phase filter explicitly assigned.
Public method GetPhaseFilterType The phase filter type of RevitLinkGraphicsSettings.
Public method GetPhaseId The linked document phase id of RevitLinkGraphicsSettings, or InvalidElementId if there is no phase explicitly assigned.
Public method GetPhaseType The phase type of RevitLinkGraphicsSettings.
Public method GetViewDetailLevel The linked document view detail level of RevitLinkGraphicsSettings.
Public method GetViewDetailLevelType The view detail level type of RevitLinkGraphicsSettings.
Public method Static member IsViewRangeSupported Returns true if the input view supports ViewRange settings of RevitLinkGraphicsSettings , false otherwise.
Public method SetDiscipline Sets discipline and discipline type of RevitLinkGraphicsSettings.
Public method SetPhase Sets phase id and phase type of RevitLinkGraphicsSettings.
Public method SetPhaseFilter Sets phase filter id and phase filter type of RevitLinkGraphicsSettings.
Public method SetViewDetailLevel Sets view detail level and detail level type of RevitLinkGraphicsSettings.
Top
See Also