DefaultFilterEntry Property


File Dialog Default Filter Entry Property

The default entry (from the filter) to be selected in the dialog.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public string DefaultFilterEntry { get; set; }

Property Value

String
This string value should be found in the string that makes up the right hand side of the filter entry. If a match is found, that entry from the filter will be shown by default when the dialog is shown. If this value is not set, or it cannot match any of the entries in the filter, it will be ignored, and the first entry in the filter will be used instead.
Exceptions
Exception Condition
ArgumentException When setting this property: defaultFilterEntry cannot include prohibited unprintable characters.
ArgumentNullException When setting this property: A non-optional argument was null
See Also