Column |
Attaches the column to the target. If an attachment already exists with the same "baseOrTop" value, no attachment is made.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static void AddColumnAttachment(
Document doc,
FamilyInstance column,
Element target,
int baseOrTop,
ColumnAttachmentCutStyle cutColumnStyle,
ColumnAttachmentJustification justification,
double attachOffset
)
Parameters
- doc Document
- The document containing column and target.
- column FamilyInstance
- A column.
- target Element
- A target element.
- baseOrTop Int32
- 0 to attach the column base, 1 to attach the column top.
- cutColumnStyle ColumnAttachmentCutStyle
- Control the handling of columns that intersect their targets.
- justification ColumnAttachmentJustification
- Control the column extent in cases where the target is not a uniform height.
- attachOffset Double
- An additional offset for the bottom. If positive, the column base or top will be higher than the attachment point; if negative, lower.

Exception | Condition |
---|---|
ArgumentException | column is not a column that supports ColumnAttachments. -or- target is not a valid target for ColumnAttachments. -or- column already has an attachment at its base or top as specified by baseOrTop. -or- column already has an attachment to target. |
ArgumentNullException | A non-optional argument was null |
ArgumentOutOfRangeException | baseOrTop must be either 0 or 1. -or- The given value for attachOffset must be no more than 30000 feet in absolute value. -or- A value passed for an enumeration argument is not a member of that enumeration |

This method modifies both column and target elements.