WaterLoopData Class


Water Loop Data Class

Represents the data and parameters of analytical water loop.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Mechanical WaterLoopData

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class WaterLoopData : IDisposable

The WaterLoopData type exposes the following members.

Properties
Name Description
Public property ChillerType The type of water chiller. Note this property change would reset the condenser water loop.
Public property CondenserWaterLoopId The water loop element id for the water cooled chiller.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property WaterLoopType The type of water loop. Note this property change would reset other properties.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the WaterLoopData
Top
See Also