Tile Class


Tile Class

A static class that provides access to the property names that appear in the Tile visual asset schema.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Visual Tile

Namespace: Autodesk.Revit.DB.Visual
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class Tile

The Tile type exposes the following members.

Properties
Name Description
Public property Static member TextureLinkTextureTransforms The property labeled "Link Transforms" from the "Tile" schema.
Public property Static member TextureOffsetLock The property labeled "Offset Lock" from the "Tile" schema.
Public property Static member TextureRealWorldOffsetX The property labeled "Offset X" from the "Tile" schema.
Public property Static member TextureRealWorldOffsetY The property labeled "Offset Y" from the "Tile" schema.
Public property Static member TextureRealWorldScaleX The property labeled "Size X" from the "Tile" schema.
Public property Static member TextureRealWorldScaleY The property labeled "Size Y" from the "Tile" schema.
Public property Static member TextureScaleLock The property labeled "Scale Lock" from the "Tile" schema.
Public property Static member TextureURepeat The property labeled "U Repeat" from the "Tile" schema.
Public property Static member TextureVRepeat The property labeled "V Repeat" from the "Tile" schema.
Public property Static member TextureWAngle The property labeled "Angle" from the "Tile" schema.
Public property Static member TileBrickColor The property labeled "Tile Color" from the "Tile" schema.
Public property Static member TileBrickType The property labeled "Type" from the "Tile" schema.
Public property Static member TileChangeColumn The property labeled "Amount" from the "Tile" schema.
Public property Static member TileChangeRow The property labeled "Amount" from the "Tile" schema.
Public property Static member TileColorVariance The property labeled "Color Variance" from the "Tile" schema.
Public property Static member TileEdgeRoughness The property labeled "Roughness" from the "Tile" schema.
Public property Static member TileFadeVariance The property labeled "Fade Variance" from the "Tile" schema.
Public property Static member TileHorizontalCount The property labeled "Tile Count" from the "Tile" schema.
Public property Static member TileHorizontalGap The property labeled "Gap Width" from the "Tile" schema.
Public property Static member TileLineShift The property labeled "Line Shift" from the "Tile" schema.
Public property Static member TileMortarColor The property labeled "Grout Color" from the "Tile" schema.
Public property Static member TilePerColumn The property labeled "Every" from the "Tile" schema.
Public property Static member TilePerRow The property labeled "Every" from the "Tile" schema.
Public property Static member TileRandomSeed The property labeled "Randomize" from the "Tile" schema.
Public property Static member TileRandomShift The property labeled "Random" from the "Tile" schema.
Public property Static member TileUseColumnEdit The property labeled "Column Modify" from the "Tile" schema.
Public property Static member TileUseRowEdit The property labeled "Row Modify" from the "Tile" schema.
Public property Static member TileVerticalCount The property labeled "tile_VerticalCount" from the "Tile" schema.
Public property Static member TileVerticalGap The property labeled "Vert" from the "Tile" schema.
Top
See Also