StraightLineMultiplier Property


Rebar Hook Type Straight Line Multiplier Property

Multiplier of bar diameter. Used to compute a default hook length. The default hook length can be overridden by the RebarBarType class.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public double StraightLineMultiplier { get; set; }

Property Value

Double
Exceptions
Exception Condition
ArgumentException When setting this property: The given value for straightLineMultiplier is not a number
ArgumentOutOfRangeException When setting this property: straightLineMultiplier must be greater than 0 and no more than 99.
See Also