GetCurveSegmentExtents Method


Solid Curve Intersection Get Curve Segment Extents Method

Gets the extents for the given curve segment generated by intersection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public CurveExtents GetCurveSegmentExtents(
	int index
)

Parameters

index Int32
The index.

Return Value

CurveExtents
The curve extents.
Exceptions
Exception Condition
ArgumentException index is out of range.
Remarks
The parameters are raw parameters based on the raw parameter extents of the original input curve.
See Also