AddDistributionSysType Method


Electrical Setting Add Distribution Sys Type Method

Add a new distribution system type to project.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public DistributionSysType AddDistributionSysType(
	string name,
	ElectricalPhase phase,
	ElectricalPhaseConfiguration phaseConfig,
	int numWire,
	VoltageType volLineToLine,
	VoltageType volLineToGround
)

Parameters

name String
The name of new added distribution system type
phase ElectricalPhase
Single or three phase this type is
phaseConfig ElectricalPhaseConfiguration
Configuration property of given phase
numWire Int32
Wire number of this distribution system
volLineToLine VoltageType
Type of line to line voltage in this system
volLineToGround VoltageType
Type of line to ground voltage in this system

Return Value

DistributionSysType
New added distribution system type object.
Exceptions
Exception Condition
ArgumentException The name can't be , empty string, or equal with any existing one, phaseConfig should be defined and numWire can only be 3 or 4 in case of three phase, numWire can only be 2 or 3 in case of single phase, otherwise exception will be thrown.
See Also