BuildingEnvelopeAnalyzerOptions Class


Building Envelope Analyzer Options Class

Specific options for the method analyzing the building elements for the building envelope.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Analysis BuildingEnvelopeAnalyzerOptions

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class BuildingEnvelopeAnalyzerOptions : IDisposable

The BuildingEnvelopeAnalyzerOptions type exposes the following members.

Constructors
Name Description
Public method BuildingEnvelopeAnalyzerOptions Constructs a new instance of BuildingEnvelopeAnalyzerOptions, using default values.
Top
Properties
Name Description
Public property AnalyzeEnclosedSpaceVolumes Whether or not to analyze interior connected regions inside the building forming enclosed space volumes.
Public property GridCellSize The cell size for the uniform cubical grid used when analyzing the building envelope.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property OptimizeGridCellSize Whether or not to use the exact value for the cell size or let the analyzer optimize the cell size based on the specified grid size
Top
Methods
Name Description
Public method Dispose Releases all resources used by the BuildingEnvelopeAnalyzerOptions
Top
Remarks
The analyze method uses a combination of ray-casting and flood-fill algorithms in order to find the building elements that are exposed to the outside of the building. The analyze method can also look for the bounding building elements for enclosed space volumes inside the building.
See Also