Slab |
Add a split line to the element.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public IList<SlabShapeCrease> AddSplitLine(
SlabShapeVertex startVertex,
SlabShapeVertex endVertex
)
Parameters
- startVertex SlabShapeVertex
- Start vertex
- endVertex SlabShapeVertex
- End vertex
Return Value
IList SlabShapeCreaseThe newly created creases after adding the split line.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |

Adding a split line may result in multiple creases, for example when the line crosses existing creases or boundary edges.