RebarShapeConstraintSegmentLength Class


Rebar Shape Constraint Segment Length Class

A constraint that controls the length of a segment.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Structure RebarShapeConstraint
Autodesk.Revit.DB.Structure RebarShapeConstraintSegmentLength

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class RebarShapeConstraintSegmentLength : RebarShapeConstraint

The RebarShapeConstraintSegmentLength type exposes the following members.

Constructors
Name Description
Public method RebarShapeConstraintSegmentLength Create a segment length constraint.
Top
Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from RebarShapeConstraint )
Top
Methods
Name Description
Public method Dispose
(Inherited from RebarShapeConstraint )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetParamId Return the Id of the parameter associated with this constraint.
(Inherited from RebarShapeConstraint )
Public method GetSegmentEndReferenceType Choice of two possibilities for the start and end references of the length constraint.
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks
The constraint has two references, indexed by 0 and 1, that do not have to correspond to the start and end of the segment.
See Also