RebarShapeConstraintSegmentLength Class


Rebar Shape Constraint Segment Length Class

A constraint that controls the length of a segment.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Structure RebarShapeConstraint
Autodesk.Revit.DB.Structure RebarShapeConstraintSegmentLength

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class RebarShapeConstraintSegmentLength : RebarShapeConstraint

The RebarShapeConstraintSegmentLength type exposes the following members.

Constructors
Name Description
Public method RebarShapeConstraintSegmentLength Create a segment length constraint.
Top
Properties
Name Description
Top
Methods
Name Description
Public method GetSegmentEndReferenceType Choice of two possibilities for the start and end references of the length constraint.
Top
Remarks
The constraint has two references, indexed by 0 and 1, that do not have to correspond to the start and end of the segment.
See Also