InitialWattageIntensity Class


Initial Wattage Intensity Class

This class encapsulates initial wattage intensity calculation.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Lighting InitialIntensity
Autodesk.Revit.DB.Lighting InitialWattageIntensity

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class InitialWattageIntensity : InitialIntensity

The InitialWattageIntensity type exposes the following members.

Constructors
Name Description
Public method InitialWattageIntensity(InitialWattageIntensity) Creates a copy of the given initial wattage intensity object
Public method InitialWattageIntensity(Double, Double) Creates an initial wattage intensity object with the given values.
Top
Properties
Name Description
Public property Efficacy The efficacy value.
Public property InitialIntensityValue The calculated initial intensity value.
(Inherited from InitialIntensity )
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from InitialIntensity )
Public property Wattage The wattage value.
Top
Methods
Name Description
Public method Clone Creates a copy of the InitialIntensity derived object.
(Inherited from InitialIntensity )
Public method Dispose
(Inherited from InitialIntensity )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also