Failure |
Checks if the FailureMessage should be merged with the other FailureMessage for better user experience.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- messageToMergeWith FailureMessageAccessor
Return Value
BooleanTrue if messages should be merged

Exception | Condition |
---|---|
ArgumentException | messageToMergeWith has not been properly initialized. |
ArgumentNullException | A non-optional argument was null |
InvalidOperationException | This FailureMessageAccessor has not been properly initialized. |

Messages should be merged if all user-visible information except failing elements is the same, failure resolution types are the same and merging lists of failing elements keeps message text applicable to all of them equally. Method is used by the Revit UI to display multiple messages as one.