Intersects Method


Outline Intersects Method

Determine if this Outline intersects the input Outline to within a specified tolerance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool Intersects(
	Outline outline,
	double tolerance
)

Parameters

outline Outline
The outline to test for intersection with this one.
tolerance Double
The tolerance to use when determining intersection. Defaults to zero.

Return Value

Boolean
True if the given outline intersects this outline.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
Remarks
If the tolerance is positive, the outlines may be separated by the tolerance distance in each coordinate. If the tolerance is negative, the outlines must overlap by at least the tolerance distance in each coordinate.
See Also