SetVertex Method


Wire Set Vertex Method

Sets the position of a given vertex. If the vertex is start or end point, and the wire connects to electrical device, the wire end offset will be set according to the given vertex. If the vertex is start or end point, and the wire connects to other wire, user can't set the vertex and exception will be thrown. If the vertex is start or end point, and the wire connects to nothing, the vertex will be set as the given vertex.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetVertex(
	int index,
	XYZ vertexPoint
)

Parameters

index Int32
The index of the existing vertex. Should be between 0 and NumberOfVertices .
vertexPoint XYZ
The new position for the vertex.
Exceptions
Exception Condition
ArgumentException The index should be between 0 and the number of vertices of the wire. -or- The vertex point cannot be added to the wire because there is already a vertex at this position on the view plane (within tolerance).
ArgumentNullException A non-optional argument was null
InvalidOperationException Can't set the vertex when the vertex is start or end point and the wire connects to other wire.
See Also