PanelSchedulePhaseLoadType Enumeration


Panel Schedule Phase Load Type Enumeration

Declares the panel schedule type. The comments for each enum type show a simple example of how the layout would look when applied to a panel schedule

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public enum PanelSchedulePhaseLoadType
Members
Member name Value Description
LoadsByPhase 4 | Ckt | A | B | C | Ckt | | 1 | 100 | x | x | | | | 200 | x | x | 2 |
LoadsByPhaseInSharedColumns 3 | Ckt | A | B | C | Ckt | | 1 | 100/200 | x | x | 2 |
LoadsByPhaseInSplitColumns 1 | Ckt | A | B | C | Ckt | | 1 | 100 | 200 | x | x | x | x | 2 |
MirroredPhaseColumns 2 | Ckt | A | B | C | A | B | C | Ckt | | 1 | 100 | x | x | 200 | x | x | 2 |
NoLoadInformation 0 No load information
SeperatePhaseLoadsPerCircuit 6 | Ckt | A | B | C | | 1 | 100 | 0 | 0 | | 2 | 200 | 0 | 0 |
TotalLoadOnlyPerCircuit 5 | Ckt | Load | | 1 | 100 | | 2 | 200 |
See Also