RemoveSpaces Method


Zone Remove Spaces Method

Remove a set of existing spaces to the current Zone element.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool RemoveSpaces(
	SpaceSet spaces
)

Parameters

spaces SpaceSet
The spaces which want to delete from the current zone element.

Return Value

Boolean
If successful the current zone element will remove a set of input spaces, otherwise .
Exceptions
Exception Condition
ArgumentNullException Thrown when the specified parameter Value is .
InvalidOperationException Thrown when the input spaces cannot be deleted from current zone element.
See Also