Subelement Class


Subelement Class

An object that represents an element or a subelement within the Autodesk Revit project.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB Subelement

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class Subelement : IDisposable

The Subelement type exposes the following members.

Properties
Name Description
Public property Category Retrieves a Category object that represents the category or sub category of the subelement.
Public property Document The document in which the subelement resides.
Public property Element The element in which the subelement resides.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property TypeId The identifier of this subelement's type.
Public property UniqueId A stable unique identifier for this subelement within the document.
Top
Methods
Name Description
Public method CanHaveTypeAssigned Identifies if the subelement can have a type assigned.
Public method ChangeTypeId Changes the type of the subelement.
Public method Static member Create Creates an object representing element or subelement.
Public method Dispose Releases all resources used by the Subelement
Public method GetAllParameters Returns all parameters of this subelement.
Public method GetBoundingBox Retrieves a box that circumscribes all geometry of the subelement.
Public method GetGeometryObject Retrieve one geometric primitive representing given subelement.
Public method GetParameterValue Obtains the current parameter value of this subelement given a parameter id.
Public method GetReference Obtains the reference to this subelement.
Public method GetValidTypes Obtains a set of types that are valid for this subelement.
Public method HasParameter Checks if this subelement have given parameter.
Public method IsParameterModifiable Checks if given parameter of this subelement is modifiable.
Public method Static member IsValidSubelementReference Checks if given Reference identifies either a valid element or subelement.
Public method IsValidType Checks if given type is valid for this subelement.
Public method SetParameterValue Sets a new parameter value of this subelement given a parameter id.
Top
Remarks

Subelements provide a way for parts of an element to behave as though they were real elements without incurring the overhead of adding more full elements to the model.

Many Revit features (for example parameters, schedules, and tags) were designed to operate on Elements. As a result, the Revit code needs to represent objects as Elements for them to participate in those features. This can lead to scalability problems, because every Element adds overhead and adding many Elements may decrease the performance of the model. An alternative is to use Subelements. An element can expose a set of "Subelements" that it contains, specifying characteristics like their category and parameters, and certain Revit capabilities will treat those Subelements the same as ordinary Elements. For example, a Subelement may contribute geometry to the main element and may be able to be selected independently of its parent Element. It will possibly have its own (settable) type as well as an assigned category which can be different from its parent Element.

In the API, the new Subelement class is used to refer to either an Element or a specific subelement of a given Element. It is typically directly related to a Reference to either the Element or the specific subelement. Note that creation of new Subelements for a given element is not done generically. Instead, the given Element may provide the ability to modify it's definition, resulting in the creation of new Subelements.

Examples of Elements which may have Subelements in practice include:

To get access to a particular Subelement, you may use any of the following:

See Also