BoundingBoxContainsPointFilter Constructor (XYZ, Double)


Bounding Box Contains Point Filter(XYZ, Double) Constructor

Constructs a new instance of a filter to match elements with a bounding box that contains the given point, while specifying the tolerance to be used in deciding if the point matches the criteria.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public BoundingBoxContainsPointFilter(
	XYZ point,
	double tolerance
)

Parameters

point XYZ
The point used to find elements with a bounding box that contains it.
tolerance Double
The tolerance value to use instead of zero. See the tolerance property for details.
Exceptions
Exception Condition
ArgumentException The given value for tolerance is not finite -or- The given value for tolerance is not a number
ArgumentNullException A non-optional argument was null
See Also