SetAllowShortEdges Method


BRep Builder Set Allow Short Edges Method

Make BRepBuilder allow edges that it would normally disallow as being too short for Revit geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetAllowShortEdges()
Exceptions
Exception Condition
InvalidOperationException This function was called after the geometry had been defined (e.g. by calls to addFace).
Remarks
When used, this function must be called before any geometry is defined (e.g., just after constructing a BRepBuilder object). Geometry with short edges may not be as reliable as fully valid geometry. This option is intended to allow the construction of geometry such as mechanical items with small features that is not expected to interact much with other Revit elements.
See Also